Telstra Mobile Outage

Incident Report for aera

Update

Telstra has confirmed that all systems are now back up and operational.
Posted Jul 09, 2026 - 07:53 AEST

Monitoring

Telstra has now published that 90% of services are back up and operational. There is no current estimated timeline for full restoration of all services.
Posted Jul 08, 2026 - 11:02 AEST

Identified

Telstra are looking into a nation-wide outage affecting cellular infrastructure.

The outage is also affecting payment systems and public transport across the country, with regional rail lines in NSW and Victoria and the ACT's MyWay+ ticketing system among those services affected.

Telstra will provide updates as soon as they have remediated these issues.

If you require assistance from our helpdesk please contact Aera on 1300 700 929 or email our support team on help@aera.com.au.
Posted Jul 08, 2026 - 10:06 AEST
This incident affects: Internet and Voice.